Sat. Mar 2nd, 2024

Um plugin muito utilizado no WordPress para assegurar a conformidade de privacidade, com uma base de mais de 800.000 instalações, recentemente solucionou uma falha XSS armazenada, que poderia dar a oportunidade para um invasor carregar scripts maliciosos e atacar os visitantes do site.

Complianz es un plugin de WordPress para el consentimiento de cookies de GDPR/CCPA, diseñado para cumplir con las regulaciones de privacidad de datos.

O Complianz é um plugin para WordPress que oferece suporte aos donos de sites na conformidade com regulamentos de privacidade, como o GDPR e a CCPA.

O plugin controla diferentes aspectos da privacidade do usuário, como bloquear cookies de terceiros, gerenciar o consentimento dos cookies (inclusive por sub-região) e lidar com diferentes aspectos dos banners de cookies.

A popularidade da ferramenta, que conta atualmente com mais de 800.000 instalações, pode ser atribuída à sua versatilidade e utilidade.

Plugin de Conformidade – Vulnerabilidade de Cross-Site Scripting Armazenada

Uma vulnerabilidade XSS armazenada foi encontrada no plugin Complianz WordPress. Esse tipo de vulnerabilidade permite que um usuário faça upload de um script malicioso diretamente para o servidor do site. Ao contrário do XSS refletido, em que é necessário que um usuário clique em um link, o XSS armazenado envolve um script malicioso armazenado e servido a partir do servidor do site alvo.

A falta de duas funções de segurança nas configurações de administração do Complianz é o motivo da vulnerabilidade.

O plugin não possuía uma verificação adequada de entrada e saída. A verificação de entrada é um procedimento padrão para garantir que o que é inserido em um site, como em um campo de formulário, corresponda ao esperado, como uma entrada de texto em vez de um upload de script.

Leia Mais:   Plano do Google para personalização de anúncios sem utilizar cookies de outras empresas.

No guia oficial do desenvolvedor do WordPress, é explicado o conceito de higienização de dados como:

A medição da entrada refere-se ao processo de segurança e filtragem dos dados de entrada para garantir sua integridade. A validação é uma opção preferível em comparação à sanitização, pois é mais precisa. No entanto, quando a precisão não é possível, a sanitização pode ser considerada a melhor alternativa.

O plugin não possuía uma função de Escaping, que é uma medida de segurança que remove informações indesejadas antes de serem exibidas para o usuário.

Qual é a gravidade da vulnerabilidade?

A vulnerabilidade exige que o invasor tenha níveis mais altos de permissão administrativa para executar o ataque. Isso pode ser a explicação para a pontuação de 4.4 em 10 para essa vulnerabilidade, onde dez representa o nível mais alto de vulnerabilidade.

A vulnerabilidade apenas impacta determinados tipos de instalações também.

Segundo a Wordfence:

Isso permite que os invasores autenticados, com privilégios de administrador ou superiores, insiram scripts da web arbitrários em páginas que serão executados sempre que um usuário acessar uma página injetada.

Isso só tem impacto em estabelecimentos e instalações com vários locais onde a opção unfiltered_html foi desativada.

Fazer a atualização para a versão mais recente.

A versão 6.5.5 do Complianz e versões anteriores estão vulneráveis, por isso é recomendado que os usuários atualizem para a versão 6.5.6 ou uma versão mais recente.

Confira o comunicado da equipe do Wordfence sobre a falha de segurança:

Complianz | GDPR/CCPA Cookie Consent versão <= 6.5.5 - Autenticado (Administrador+) vulnerabilidade de Cross-site Scripting armazenada através das configurações.